InnoDB: Warning: io_setup() failed with EAGAIN. Will make 5 attempts before giving up.


Entah kenapa mysql service mati secara mendadak. cek log terjadi permasalahan di engine inodbnya.

140420 2:30:52 [Note] Plugin 'FEDERATED' is disabled.
140420 2:30:52 InnoDB: The InnoDB memory heap is disabled
140420 2:30:52 InnoDB: Mutexes and rw_locks use InnoDB's own implementation
140420 2:30:52 InnoDB: Compressed tables use zlib 1.2.3
140420 2:30:52 InnoDB: Using Linux native AIO
140420 2:30:52 InnoDB: Warning: io_setup() failed with EAGAIN. Will make 5 attempts before giving up.
InnoDB: Warning: io_setup() attempt 1 failed.
InnoDB: Warning: io_setup() attempt 2 failed.
InnoDB: Warning: io_setup() attempt 3 failed.
InnoDB: Warning: io_setup() attempt 4 failed.
InnoDB: Warning: io_setup() attempt 5 failed.
140420 2:30:55 InnoDB: Error: io_setup() failed with EAGAIN after 5 attempts.
InnoDB: You can disable Linux Native AIO by setting innodb_use_native_aio = 0 in my.cnf
140420 2:30:55 InnoDB: Fatal error: cannot initialize AIO sub-system
140420 2:30:55 [ERROR] Plugin 'InnoDB' init function returned error.
140420 2:30:55 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
140420 2:30:55 [ERROR] Unknown/unsupported storage engine: InnoDB
140420 2:30:55 [ERROR] Aborting

140420 2:30:55 [Note] /usr/sbin/mysqld: Shutdown complete

hasil penelusuran, memberikan solusi penambahan di my.cnf

innodb_use_native_aio=0

solusi lain tapi belum dicoba adalah
#echo 65536 > /proc/sys/fs/aio-max-nr

atau di my.cnf

ignore_builtin_innodb
default_storage_engine=MyISAM

yang lebih sadis lagi
skip-innodb

flattr this!


Leave a Reply

Your email address will not be published. Required fields are marked *